Sergey Solomin | aac4adf | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 1 | SUMMARY = "POWER9 VCS workaround" |
| 2 | DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit obmc-phosphor-systemd |
| 6 | inherit obmc-phosphor-license |
| 7 | |
Matt Spinler | aca1b15 | 2017-03-10 15:08:56 -0600 | [diff] [blame] | 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:" |
| 9 | RDEPENDS_${PN} += "virtual-p9-vcs-workaround op-proc-control" |
Sergey Solomin | aac4adf | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}" |
Sergey Solomin | aac4adf | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 12 | |
| 13 | TMPL = "vcs_workaround@.service" |
| 14 | INSTFMT = "vcs_workaround@{0}.service" |
Josh D. King | b9ee536 | 2017-04-06 14:43:46 -0500 | [diff] [blame] | 15 | TGTFMT = "obmc-chassis-poweron@{0}.target" |
Andrew Geissler | 3c35a8c | 2017-02-08 15:54:25 -0600 | [diff] [blame] | 16 | FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}" |
Sergey Solomin | aac4adf | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 17 | |
| 18 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 19 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |