Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "File synchronization tool" |
| 2 | HOMEPAGE = "http://rsync.samba.org/" |
| 3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" |
| 4 | SECTION = "console/network" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) |
| 6 | LICENSE = "GPLv3+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | DEPENDS = "popt" |
| 10 | |
| 11 | SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \ |
| 12 | file://rsyncd.conf \ |
| 13 | file://makefile-no-rebuild.patch \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame^] | 14 | file://CVE-2016-9840.patch \ |
| 15 | file://CVE-2016-9841.patch \ |
| 16 | file://CVE-2016-9842.patch \ |
| 17 | file://CVE-2016-9843.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf" |
| 21 | SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0" |
| 22 | |
| 23 | inherit autotools |
| 24 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | PACKAGECONFIG ??= "acl attr \ |
| 26 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 27 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 30 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | |
| 33 | # By default, if crosscompiling, rsync disables a number of |
| 34 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 35 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 36 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | EXTRA_OEMAKE = 'STRIP=""' |
| 38 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 39 | # rsync 3.0 uses configure.sh instead of configure, and |
| 40 | # makefile checks the existence of configure.sh |
| 41 | do_configure_prepend () { |
| 42 | rm -f ${S}/configure ${S}/configure.sh |
| 43 | } |
| 44 | |
| 45 | do_configure_append () { |
| 46 | cp -f ${S}/configure ${S}/configure.sh |
| 47 | } |
| 48 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 49 | do_install_append() { |
| 50 | install -d ${D}${sysconfdir} |
| 51 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} |
| 52 | } |
| 53 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 54 | BBCLASSEXTEND = "native" |