Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP and WebDAV client library with a C interface" |
| 2 | HOMEPAGE = "http://www.webdav.org/neon/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPL-2.0-or-later" |
| 5 | LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \ |
| 6 | file://src/ne_utils.h;beginline=1;endline=20;md5=34c8e338bfa0237561e68d30c3c71133" |
| 7 | |
| 8 | SRC_URI = "${DEBIAN_MIRROR}/main/n/neon27/neon27_${PV}.orig.tar.gz \ |
| 9 | file://pkgconfig.patch \ |
| 10 | file://0001-Disable-installing-documentation.patch \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "1bcdaabb63206b5e00c9a8c4b3672168b523b49eb559c5a486e3256463af34fd" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 15 | |
| 16 | inherit autotools-brokensep binconfig-disabled lib_package pkgconfig ptest |
| 17 | |
| 18 | # Enable gnutls or openssl, not both |
| 19 | PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib nls" |
| 20 | PACKAGECONFIG:class-native = "expat gnutls webdav zlib nls" |
| 21 | PACKAGECONFIG:remove:libc-musl = "nls" |
| 22 | |
| 23 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat" |
| 24 | PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls" |
| 25 | PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5" |
| 26 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy" |
| 27 | PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2" |
| 28 | PACKAGECONFIG[nls] = ",--disable-nls,gettext-native" |
| 29 | PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl" |
| 30 | PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav," |
| 31 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib" |
| 32 | |
| 33 | EXTRA_OECONF += "--enable-shared --enable-threadsafe-ssl=posix" |
| 34 | |
| 35 | # Do not install into /usr/local |
| 36 | EXTRA_OEMAKE:append:class-native = "prefix=${prefix_native}" |
| 37 | |
| 38 | do_configure:prepend() { |
| 39 | echo "${PV}" > ${S}/.version |
| 40 | } |
| 41 | |
| 42 | do_compile:append() { |
| 43 | if ${@bb.utils.contains('PACKAGECONFIG', 'nls', 'true', 'false', d)}; then |
| 44 | oe_runmake compile-gmo |
| 45 | fi |
| 46 | oe_runmake -C test |
| 47 | } |
| 48 | |
| 49 | do_install_ptest(){ |
| 50 | BASIC_TESTS="auth basic redirect request session socket string-tests \ |
| 51 | stubs uri-tests util-tests" |
| 52 | DAV_TESTS="acl3744 lock oldacl props xml xmlreq" |
| 53 | mkdir "${D}${PTEST_PATH}/test" |
| 54 | for i in ${BASIC_TESTS} ${DAV_TESTS} |
| 55 | do |
| 56 | install -m 0755 "${B}/test/${i}" \ |
| 57 | "${D}${PTEST_PATH}/test" |
| 58 | done |
| 59 | } |
| 60 | |
| 61 | BINCONFIG = "${bindir}/neon-config" |
| 62 | |
| 63 | BBCLASSEXTEND = "native" |