Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Receive a forwarded serial from serial-forward and provide a PTY" |
| 2 | AUTHOR = "Holger 'Zecke' Freyther" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07" |
| 5 | SECTION = "console/network" |
| 6 | SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec" |
| 7 | PV = "1.1+gitr${SRCPV}" |
| 8 | |
| 9 | SRC_URI = "git://github.com/freesmartphone/cornucopia.git;protocol=https" |
| 10 | S = "${WORKDIR}/git/tools/serial_forward" |
| 11 | |
| 12 | inherit autotools native |
| 13 | |
| 14 | do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_IMAGE}" |
| 15 | do_deploy() { |
| 16 | install -d ${DEPLOY_DIR_IMAGE} |
| 17 | install -m 0755 ${B}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward |
| 18 | } |
| 19 | |
| 20 | addtask deploy before do_package after do_install |