Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program." |
| 2 | SECTION = "examples" |
| 3 | HOMEPAGE = "https://golang.org/" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | SRC_URI = "git://${GO_IMPORT}" |
| 9 | SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | UPSTREAM_CHECK_COMMITS = "1" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | GO_IMPORT = "github.com/golang/example" |
| 13 | GO_INSTALL = "${GO_IMPORT}/hello" |
| 14 | |
| 15 | inherit go |
| 16 | |
| 17 | # This is just to make clear where this example is |
| 18 | do_install_append() { |
| 19 | mv ${D}${bindir}/hello ${D}${bindir}/${BPN} |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | } |