Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \ |
| 6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ |
| 7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \ |
| 8 | " |
| 9 | |
| 10 | inherit module |
| 11 | |
| 12 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux' |
| 13 | |
| 14 | #https://lttng.org/files/lttng-modules/lttng-modules-2.10.7.tar.bz2 |
| 15 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 16 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| 17 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| 18 | file://0001-Fix-net-expose-sk-wmem-in-sock_exceed_buf_limit-trac.patch \ |
| 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "d3cb4520948083bf1573a2e4cb7406aa" |
| 22 | SRC_URI[sha256sum] = "f049428d3d131e103a7a7038d184731bf7bcdce00503fc19a2c9b5693ecbb3b5" |
| 23 | |
| 24 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 25 | |
| 26 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 27 | |
| 28 | do_install_append() { |
| 29 | # Delete empty directories to avoid QA failures if no modules were built |
| 30 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 31 | } |
| 32 | |
| 33 | python do_package_prepend() { |
| 34 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 35 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 36 | } |
| 37 | |