Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Additional utilities for the opkg package manager" |
| 2 | SUMMARY:update-alternatives-opkg = "Utility for managing the alternatives system" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986" |
| 8 | PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}" |
| 9 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 10 | SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=https;branch=master \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | file://0001-update-alternatives-correctly-match-priority.patch \ |
| 12 | " |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 13 | SRCREV = "9239541f14a2529b9d01c0a253ab11afa2822dab" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | |
| 17 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 18 | |
| 19 | RDEPENDS:${PN} += "bash" |
| 20 | |
| 21 | inherit perlnative |
| 22 | |
| 23 | # For native builds we use the host Python |
| 24 | PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold" |
| 25 | PYTHONRDEPS:class-native = "" |
| 26 | |
| 27 | PACKAGECONFIG = "python update-alternatives" |
| 28 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" |
| 29 | PACKAGECONFIG[update-alternatives] = ",,," |
| 30 | |
| 31 | do_install() { |
| 32 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 33 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then |
| 34 | rm -f "${D}${bindir}/update-alternatives" |
| 35 | fi |
| 36 | } |
| 37 | |
| 38 | do_install:append:class-target() { |
| 39 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then |
| 40 | grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm |
| 41 | fi |
| 42 | |
| 43 | if [ -e "${D}${bindir}/update-alternatives" ]; then |
| 44 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g' |
| 45 | fi |
| 46 | } |
| 47 | |
| 48 | # These are empty and will pull python3-dev into images where it wouldn't |
| 49 | # have been otherwise, so don't generate them. |
| 50 | PACKAGES:remove = "${PN}-dev ${PN}-staticdev" |
| 51 | |
| 52 | PACKAGES =+ "update-alternatives-opkg" |
| 53 | FILES:update-alternatives-opkg = "${bindir}/update-alternatives" |
| 54 | RPROVIDES:update-alternatives-opkg = "update-alternatives update-alternatives-cworth" |
| 55 | RREPLACES:update-alternatives-opkg = "update-alternatives-cworth" |
| 56 | RCONFLICTS:update-alternatives-opkg = "update-alternatives-cworth" |
| 57 | |
| 58 | pkg_postrm:update-alternatives-opkg() { |
| 59 | rm -rf $D${nonarch_libdir}/opkg/alternatives |
| 60 | rmdir $D${nonarch_libdir}/opkg || true |
| 61 | } |
| 62 | |
| 63 | BBCLASSEXTEND = "native nativesdk" |
| 64 | |
| 65 | CLEANBROKEN = "1" |