Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor machine readable workbook patching script" |
| 2 | DESCRIPTION = "Retrieve the script that can patch the MRW XML" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/git" |
| 6 | |
| 7 | inherit obmc-phosphor-license |
| 8 | inherit native |
| 9 | |
| 10 | DEPENDS += "python-native python-lxml-native" |
| 11 | |
| 12 | SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools" |
Patrick Williams | 0dbedc1 | 2016-09-14 22:00:07 -0500 | [diff] [blame] | 13 | SRCREV = "7a68567af7bf121143ef135152a39723518b6e06" |
Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 14 | |
| 15 | do_install() { |
Matt Spinler | 98c33e3 | 2016-09-20 13:32:44 -0500 | [diff] [blame^] | 16 | install -d ${D}${bindir}/obmc-mrw |
| 17 | install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw |
Matt Spinler | 1b8b904 | 2016-08-25 13:04:09 -0500 | [diff] [blame] | 18 | } |