Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 1 | require recipes-devtools/atp/atp-source_3.1.inc |
| 2 | |
| 3 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" |
| 4 | |
| 5 | SRC_URI += "${ATP_SRC};destsuffix=git/atp;name=atp \ |
| 6 | file://start-gem5-atp.sh" |
| 7 | SRCREV_FORMAT = "gem5_atp" |
| 8 | SRCREV_atp = "${ATP_REV}" |
| 9 | LICENSE += "& ${ATP_LIC}" |
| 10 | LIC_FILES_CHKSUM += "file://atp/LICENSE;md5=${ATP_LIC_MD5}" |
| 11 | |
| 12 | EXTRA_OESCONS += "EXTRAS=${S}/atp" |
| 13 | |
| 14 | do_install:append() { |
| 15 | # baremetal_atp.py machine configuration and sample stream.atp file |
| 16 | install -m 644 ${B}/atp/gem5/baremetal_atp.py \ |
| 17 | ${B}/atp/configs/stream.atp \ |
| 18 | ${D}${datadir}/gem5/configs |
| 19 | } |
| 20 | |
| 21 | do_deploy:append() { |
| 22 | # start-gem5-atp.sh launch script |
| 23 | install -m 755 ${WORKDIR}/start-gem5-atp.sh ${DEPLOYDIR} |
| 24 | } |