Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "GNOME library for reading .desktop files" |
| 2 | SECTION = "x11/gnome" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-only & LGPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 7 | " |
| 8 | |
| 9 | GNOMEBASEBUILDCLASS = "meson" |
| 10 | |
| 11 | inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check gtk-doc |
| 12 | |
| 13 | REQUIRED_DISTRO_FEATURES = "x11" |
| 14 | # gobject-introspection is mandatory and cannot be configured |
| 15 | REQUIRED_DISTRO_FEATURES += "gobject-introspection-data" |
| 16 | |
| 17 | GIR_MESON_OPTION = "" |
| 18 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 19 | SRC_URI[archive.sha256sum] = "f3caa293a5e86f6ccad18f817273db1c67061e680d79d839aa8a7528e5bb26d6" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | SRC_URI += " \ |
| 21 | file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \ |
| 22 | file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \ |
| 23 | " |
| 24 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 25 | DEPENDS += " \ |
| 26 | gsettings-desktop-schemas \ |
| 27 | virtual/libx11 \ |
| 28 | gtk+3 \ |
| 29 | gtk4 \ |
| 30 | startup-notification \ |
| 31 | xkeyboard-config \ |
| 32 | iso-codes \ |
| 33 | udev \ |
| 34 | " |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 35 | |
| 36 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 37 | EXTRA_OEMESON = "-Ddesktop_docs=false" |
| 38 | |
| 39 | PACKAGES =+ "libgnome-desktop" |
| 40 | RDEPENDS:${PN} += "libgnome-desktop" |
| 41 | FILES:libgnome-desktop = " \ |
| 42 | ${libdir}/lib*${SOLIBS} \ |
| 43 | ${datadir}/libgnome-desktop*/pnp.ids \ |
| 44 | ${datadir}/gnome/*xml \ |
| 45 | " |
| 46 | |
| 47 | RRECOMMENDS:libgnome-desktop += "gsettings-desktop-schemas" |