blob: aae927a70b4f5a5e4e880ff301fd518ac3186532 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME library for reading .desktop files"
2SECTION = "x11/gnome"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only & LGPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = " \
5 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
7"
8
9GNOMEBASEBUILDCLASS = "meson"
10
11inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check gtk-doc
12
13REQUIRED_DISTRO_FEATURES = "x11"
14# gobject-introspection is mandatory and cannot be configured
15REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
16
17GIR_MESON_OPTION = ""
18
Patrick Williamsde0582f2022-04-08 10:23:27 -050019SRC_URI[archive.sha256sum] = "f3caa293a5e86f6ccad18f817273db1c67061e680d79d839aa8a7528e5bb26d6"
Andrew Geissler595f6302022-01-24 19:11:47 +000020SRC_URI += " \
21 file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \
22 file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \
23"
24
Patrick Williamsde0582f2022-04-08 10:23:27 -050025DEPENDS += " \
26 gsettings-desktop-schemas \
27 virtual/libx11 \
28 gtk+3 \
29 gtk4 \
30 startup-notification \
31 xkeyboard-config \
32 iso-codes \
33 udev \
34"
Andrew Geissler595f6302022-01-24 19:11:47 +000035
36GTKDOC_MESON_OPTION = "gtk_doc"
37EXTRA_OEMESON = "-Ddesktop_docs=false"
38
39PACKAGES =+ "libgnome-desktop"
40RDEPENDS:${PN} += "libgnome-desktop"
41FILES:libgnome-desktop = " \
42 ${libdir}/lib*${SOLIBS} \
43 ${datadir}/libgnome-desktop*/pnp.ids \
44 ${datadir}/gnome/*xml \
45"
46
47RRECOMMENDS:libgnome-desktop += "gsettings-desktop-schemas"