Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Window navigation construction toolkit" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "LGPL-2.0-only" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 4 | |
| 5 | BPN = "libwnck" |
| 6 | |
| 7 | SECTION = "x11/libs" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 8 | DEPENDS = "intltool-native gnome-common-native gtk+3 gdk-pixbuf-native" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 10 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 11 | PACKAGECONFIG[x11] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification libxres" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | |
| 13 | GNOMEBASEBUILDCLASS = "meson" |
| 14 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 15 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 16 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 17 | |
| 18 | inherit gnomebase gobject-introspection gtk-doc gettext features_check |
| 19 | |
| 20 | def gnome_verdir(v): |
| 21 | return oe.utils.trim_version(v, 1) |
| 22 | |
| 23 | SRC_URI[archive.sha256sum] = "03134fa114ef3fbe34075aa83678f58aa2debe9fcef4ea23c0779e28601d6611" |
| 24 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 25 | # gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG. |
| 26 | # cairo would at least needed to be built with xlib. |
| 27 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |