Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Simplified object serialization in python" |
| 2 | DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes." |
| 3 | AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>" |
| 4 | HOMEPAGE = "https://github.com/marshmallow-code/marshmallow" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "\ |
| 7 | file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \ |
| 8 | file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb" |
| 9 | |
| 10 | SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev" |
| 11 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 12 | SRCREV = "2805f32461fc7801a5f7b6d83facf7cbb8bca278" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit setuptools3 |
| 17 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | PIP_INSTALL_PACKAGE = "marshmallow" |
| 19 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN} += " \ |
| 21 | python3-core \ |
| 22 | python3-datetime \ |
| 23 | python3-netclient \ |
| 24 | python3-numbers \ |
| 25 | python3-json \ |
| 26 | python3-pprint \ |
| 27 | python3-packaging \ |
| 28 | " |