Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "pandas library for high-performance data analysis tools" |
| 2 | DESCRIPTION = "pandas is an open source, BSD-licensed library providing \ |
| 3 | high-performance, easy-to-use data structures and data analysis tools for \ |
| 4 | the Python programming language." |
| 5 | HOMEPAGE = "http://pandas.pydata.org/" |
| 6 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "249cec5f2a5b22096440bd85c33106b6102e0672204abd2d5c014106459804ee" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \ |
| 15 | " |
| 16 | |
| 17 | CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations" |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | ${PYTHON_PN}-json \ |
| 21 | ${PYTHON_PN}-numpy \ |
| 22 | ${PYTHON_PN}-dateutil \ |
| 23 | ${PYTHON_PN}-dateutil-zoneinfo \ |
| 24 | ${PYTHON_PN}-pytz \ |
| 25 | ${PYTHON_PN}-profile \ |
| 26 | " |