Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master" |
| 9 | SRCREV = "03493cb69e91c29718ff9f645514355cd99762c6" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | DEPENDS = "coreutils-native" |
| 13 | |
| 14 | PROVIDES = "stress" |
| 15 | RPROVIDES:${PN} = "stress" |
| 16 | RREPLACES:${PN} = "stress" |
| 17 | RCONFLICTS:${PN} = "stress" |
| 18 | |
| 19 | inherit bash-completion |
| 20 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 21 | EXTRA_OEMAKE = "VERBOSE=1" |
| 22 | |
| 23 | do_configure() { |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | mkdir -p configs |
| 25 | touch configs/HAVE_APPARMOR |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 26 | oe_runmake makeconfig |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 27 | } |
| 28 | |
| 29 | do_install() { |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 30 | oe_runmake DESTDIR=${D} BINDIR=${bindir} install |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 31 | ln -s stress-ng ${D}${bindir}/stress |
| 32 | } |