Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "Free Lossless Audio Codec" |
| 2 | DESCRIPTION = "FLAC stands for Free Lossless Audio Codec, a lossless audio compression format." |
| 3 | HOMEPAGE = "https://xiph.org/flac/" |
| 4 | BUGTRACKER = "https://github.com/xiph/flac/issues" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "GFDL-1.2 & GPL-2.0-or-later & LGPL-2.1-or-later & BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING.FDL;md5=ad1419ecc56e060eccf8184a87c4285f \ |
| 8 | file://src/Makefile.am;beginline=1;endline=17;md5=146d2c8c2fd287545cc1bd81f31e8758 \ |
| 9 | file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 10 | file://src/flac/main.c;beginline=1;endline=18;md5=893456854ce6bf14a1a7ea77266eebab \ |
| 11 | file://COPYING.LGPL;md5=fbc093901857fcd118f065f900982c24 \ |
| 12 | file://src/plugin_common/all.h;beginline=1;endline=18;md5=73c74192ce89ee6238d15a171e00c971 \ |
| 13 | file://COPYING.Xiph;md5=3d6da238b5b57a0965d6730291119f65 \ |
| 14 | file://include/FLAC/all.h;beginline=65;endline=70;md5=64474f2b22e9e77b28d8b8b25c983a48" |
| 15 | |
| 16 | SRC_URI = "http://downloads.xiph.org/releases/flac/${BP}.tar.xz" |
| 17 | SRC_URI[sha256sum] = "af41c0733c93c237c3e52f64dd87e3b0d9af38259f1c7d11e8cbf583c48c2506" |
| 18 | |
| 19 | CVE_PRODUCT = "libflac flac" |
| 20 | |
| 21 | inherit autotools gettext |
| 22 | |
| 23 | EXTRA_OECONF = "--disable-oggtest \ |
| 24 | --disable-xmms-plugin \ |
| 25 | --without-libiconv-prefix \ |
| 26 | ac_cv_prog_NASM="" \ |
| 27 | " |
| 28 | |
| 29 | PACKAGECONFIG ??= " \ |
| 30 | ${@bb.utils.filter("TUNE_FEATURES", "altivec vsx", d)} \ |
| 31 | ${@bb.utils.contains_any("TUNE_FEATURES", "core2 corei7", "sse", "", d)} \ |
| 32 | ogg \ |
| 33 | " |
| 34 | PACKAGECONFIG[sse] = "--enable-sse,--disable-sse" |
| 35 | PACKAGECONFIG[altivec] = "--enable-altivec,--disable-altivec" |
| 36 | PACKAGECONFIG[vsx] = "--enable-vsx,--disable-vsx" |
| 37 | PACKAGECONFIG[avx] = "--enable-avx,--disable-avx" |
| 38 | PACKAGECONFIG[ogg] = "--enable-ogg --with-ogg-libraries=${STAGING_LIBDIR} --with-ogg-includes=${STAGING_INCDIR},--disable-ogg,libogg" |
| 39 | |
| 40 | PACKAGES += "libflac libflac++" |
| 41 | FILES:${PN} = "${bindir}/*" |
| 42 | FILES:libflac = "${libdir}/libFLAC.so.*" |
| 43 | FILES:libflac++ = "${libdir}/libFLAC++.so.*" |