Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)" |
| 2 | HOMEPAGE = "http://www.gnupg.org/" |
| 3 | LICENSE = "GPLv3 & LGPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \ |
| 5 | file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257" |
| 6 | |
| 7 | DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt" |
| 8 | |
| 9 | inherit autotools gettext texinfo pkgconfig |
| 10 | |
| 11 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 12 | SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 13 | file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \ |
| 14 | file://0002-use-pkgconfig-instead-of-npth-config.patch \ |
| 15 | file://0003-dirmngr-uses-libgpg-error.patch \ |
| 16 | file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \ |
| 17 | file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \ |
| 18 | " |
| 19 | SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \ |
| 20 | file://relocate.patch" |
| 21 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 22 | SRC_URI[md5sum] = "1ba2d9b70c377f8e967742064c27a19c" |
| 23 | SRC_URI[sha256sum] = "afa262868e39b651a2db4c071fba90415154243e83a830ca00516f9a807fd514" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | |
| 25 | EXTRA_OECONF = "--disable-ldap \ |
| 26 | --disable-ccid-driver \ |
| 27 | --with-zlib=${STAGING_LIBDIR}/.. \ |
| 28 | --with-bzip2=${STAGING_LIBDIR}/.. \ |
| 29 | --with-readline=${STAGING_LIBDIR}/.. \ |
| 30 | --enable-gpg-is-gpg2 \ |
| 31 | " |
| 32 | RRECOMMENDS_${PN} = "pinentry" |
| 33 | |
| 34 | do_configure_prepend () { |
| 35 | # Else these could be used in prefernce to those in aclocal-copy |
| 36 | rm -f ${S}/m4/gpg-error.m4 |
| 37 | rm -f ${S}/m4/libassuan.m4 |
| 38 | rm -f ${S}/m4/ksba.m4 |
| 39 | rm -f ${S}/m4/libgcrypt.m4 |
| 40 | } |
| 41 | |
| 42 | do_install_append() { |
| 43 | ln -sf gpg2 ${D}${bindir}/gpg |
| 44 | ln -sf gpgv2 ${D}${bindir}/gpgv |
| 45 | } |
| 46 | |
| 47 | do_install_append_class-native() { |
| 48 | create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE} |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 49 | create_wrapper ${D}${bindir}/gpgconf GNUPG_BINDIR=${STAGING_BINDIR_NATIVE} |
| 50 | create_wrapper ${D}${bindir}/gpg-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE} |
| 51 | create_wrapper ${D}${bindir}/gpg-connect-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE} |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 52 | } |
| 53 | |
| 54 | PACKAGECONFIG ??= "gnutls" |
| 55 | PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls" |
| 56 | PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3" |
| 57 | |
| 58 | BBCLASSEXTEND = "native" |