Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Lightweight UPnP IGD daemon" |
| 2 | DESCRIPTION = "The miniUPnP daemon is an UPnP IGD (internet gateway device) \ |
| 3 | which provide NAT traversal services to any UPnP enabled client on \ |
| 4 | the network." |
| 5 | |
| 6 | SECTION = "networking" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aa71c78c373ccfe0ff207af0cd966d91" |
| 9 | |
| 10 | inherit autotools gettext pkgconfig |
| 11 | |
| 12 | DEPENDS += "iptables net-tools util-linux libmnl libnetfilter-conntrack" |
| 13 | |
| 14 | SRC_URI = "http://miniupnp.tuxfamily.org/files/download.php?file=${P}.tar.gz;downloadfilename=${P}.tar.gz \ |
| 15 | " |
| 16 | SRC_URI[md5sum] = "1c07a215dd9b362e75a9efc05e2fb3b4" |
| 17 | SRC_URI[sha256sum] = "d96aa3a00e0f5490826bba3cb97e68cd27479e5839adac4b9bcb66eae786bfb7" |
| 18 | |
| 19 | IPV6 = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '--ipv6', '', d)}" |
| 20 | |
| 21 | do_compile() { |
| 22 | cd ${S} |
| 23 | CONFIG_OPTIONS="${IPV6} --leasefile --vendorcfg" oe_runmake -f Makefile.linux |
| 24 | } |
| 25 | |
| 26 | do_install() { |
| 27 | install -d ${D}/${sbindir} |
| 28 | install ${S}/miniupnpd ${D}/${sbindir} |
| 29 | install -d ${D}/${sysconfdir}/${BPN} |
| 30 | install ${S}/netfilter/iptables_init.sh ${D}/${sysconfdir}/${BPN} |
| 31 | install ${S}/netfilter/iptables_removeall.sh ${D}/${sysconfdir}/${BPN} |
| 32 | install ${S}/netfilter/ip6tables_init.sh ${D}/${sysconfdir}/${BPN} |
| 33 | install ${S}/netfilter/ip6tables_removeall.sh ${D}/${sysconfdir}/${BPN} |
| 34 | install -m 0644 -b ${S}/miniupnpd.conf ${D}/${sysconfdir}/${BPN} |
| 35 | install -d ${D}/${sysconfdir}/init.d |
| 36 | install ${S}/linux/miniupnpd.init.d.script ${D}/${sysconfdir}/init.d/miniupnpd |
| 37 | } |