Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 1 | # Provides the config file for the phosphor-fan-presence application. |
| 2 | # The default config file is empty. To provide a real one, |
| 3 | # append this recipe in a layer, add: |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 4 | # FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 5 | # and provide a config file. |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 6 | SUMMARY = "Config file for phosphor-fan-presence" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 7 | LICENSE = "Apache-2.0" |
Brad Bishop | 6f3f0aa | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame^] | 9 | PROVIDES += "virtual/phosphor-fan-presence-config" |
| 10 | PR = "r1" |
| 11 | |
| 12 | SRC_URI = "file://config.yaml" |
| 13 | |
| 14 | S = "${WORKDIR}" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 15 | |
| 16 | inherit allarch |
| 17 | inherit phosphor-fan |
| 18 | |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 19 | do_install() { |
| 20 | install -D config.yaml ${D}${presence_datadir}/config.yaml |
| 21 | } |
| 22 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 23 | FILES:${PN} += "${presence_datadir}/config.yaml" |