Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Interface for user-level network packet capture" |
| 2 | DESCRIPTION = "Libpcap provides a portable framework for low-level network \ |
| 3 | monitoring. Libpcap can provide network statistics collection, \ |
| 4 | security monitoring and network debugging." |
| 5 | HOMEPAGE = "http://www.tcpdump.org/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577" |
| 7 | SECTION = "libs/network" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \ |
| 10 | file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2" |
| 11 | DEPENDS = "flex-native bison-native" |
| 12 | |
| 13 | SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "2a8885c403516cf7b0933ed4b14d6caa30e02052489ebd414dc75ac52e7559e6" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | inherit autotools binconfig-disabled pkgconfig |
| 17 | |
| 18 | BINCONFIG = "${bindir}/pcap-config" |
| 19 | |
| 20 | # Explicitly disable dag support. We don't have recipe for it and if enabled here, |
| 21 | # configure script poisons the include dirs with /usr/local/include even when the |
| 22 | # support hasn't been detected. Do the same thing for DPDK. |
| 23 | EXTRA_OECONF = " \ |
| 24 | --with-pcap=linux \ |
| 25 | --without-dag \ |
| 26 | --without-dpdk \ |
| 27 | " |
| 28 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 29 | |
| 30 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \ |
| 31 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 32 | " |
| 33 | PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5" |
| 34 | PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus" |
| 35 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 36 | PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl" |
| 37 | |
| 38 | do_configure:prepend () { |
| 39 | #remove hardcoded references to /usr/include |
| 40 | sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |