Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
| 2 | DESCRIPTION = "Library provides support for the Tag Image File Format \ |
| 3 | (TIFF), a widely used format for storing image data. This library \ |
| 4 | provide means to easily access and create TIFF image files." |
| 5 | HOMEPAGE = "http://www.libtiff.org/" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3" |
| 8 | |
| 9 | CVE_PRODUCT = "libtiff" |
| 10 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 11 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
| 12 | file://CVE-2022-48281.patch" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | |
| 14 | SRC_URI[sha256sum] = "c7a1d9296649233979fa3eacffef3fa024d73d05d589cb622727b5b08c423464" |
| 15 | |
| 16 | # exclude betas |
| 17 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 18 | |
| 19 | # Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 |
| 20 | # and 4.3.0 doesn't have the issue |
| 21 | CVE_CHECK_IGNORE += "CVE-2015-7313" |
| 22 | # These issues only affect libtiff post-4.3.0 but before 4.4.0, |
| 23 | # caused by 3079627e and fixed by b4e79bfa. |
| 24 | CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623" |
| 25 | # Issue is in jbig which we don't enable |
| 26 | CVE_CHECK_IGNORE += "CVE-2022-1210" |
| 27 | |
| 28 | inherit autotools multilib_header |
| 29 | |
| 30 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 31 | |
| 32 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 33 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 34 | |
| 35 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 36 | PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig," |
| 37 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 38 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 39 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 40 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp," |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 41 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd," |
| 42 | PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate," |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 43 | |
| 44 | # Convert single-strip uncompressed images to multiple strips of specified |
| 45 | # size (default: 8192) to reduce memory usage |
| 46 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 47 | |
| 48 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 49 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 50 | |
| 51 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 52 | # the tag |
| 53 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 54 | |
| 55 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 56 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 57 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 58 | |
| 59 | PACKAGES =+ "tiffxx tiff-utils" |
| 60 | FILES:tiffxx = "${libdir}/libtiffxx.so.*" |
| 61 | FILES:tiff-utils = "${bindir}/*" |
| 62 | |
| 63 | do_install:append() { |
| 64 | oe_multilib_header tiffconf.h |
| 65 | } |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |