Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A partition editor to graphically manage disk partitions " |
| 2 | HOMEPAGE = "http://gparted.org/index.php" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 3 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | |
| 6 | inherit features_check autotools pkgconfig python3native gnome-help gtk-icon-cache |
| 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
| 12 | file://0001-Install-polkit-action-unconditionally-executable-pke.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | file://0001-Do-not-use-NULL-where-boolean-is-expected.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | " |
| 15 | SRC_URI[sha256sum] = "5eee2e6d74b15ef96b13b3a2310c868ed2298e03341021e7d12a5a98a1d1e109" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/gparted/files/gparted/" |
| 18 | UPSTREAM_CHECK_REGEX = "gparted-(?P<pver>\d+\.(\d+)+(\.\d+)+)" |
| 19 | |
| 20 | DEPENDS += " \ |
| 21 | glib-2.0-native \ |
| 22 | yelp-tools-native \ |
| 23 | intltool-native \ |
| 24 | glib-2.0 \ |
| 25 | gtkmm3 \ |
| 26 | parted \ |
| 27 | " |
| 28 | |
| 29 | FILES:${PN} += " \ |
| 30 | ${datadir}/appdata \ |
| 31 | ${datadir}/icons \ |
| 32 | " |
| 33 | |
| 34 | PACKAGES += "${PN}-polkit" |
| 35 | FILES:${PN}-polkit = "${datadir}/polkit-1" |
| 36 | |
| 37 | RDEPENDS:${PN} = " \ |
| 38 | ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', '${PN}-polkit', '', d)} \ |
| 39 | dosfstools \ |
| 40 | mtools \ |
| 41 | e2fsprogs \ |
| 42 | " |