Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 7 | CVE_PRODUCT = "json-for-modern-cpp" |
| 8 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1;protocol=https \ |
| 10 | " |
| 11 | |
| 12 | SRCREV = "4f8fba14066156b73f1189a2b8bd568bde5284c5" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake |
| 17 | |
| 18 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 19 | |
| 20 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
| 21 | |
| 22 | RDEPENDS:${PN}-dev = "" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |
| 25 | |
| 26 | # other packages commonly reference the file directly as "json.hpp" |
| 27 | # create symlink to allow this usage |
| 28 | do_install:append() { |
| 29 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 30 | } |