Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. " |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 2 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08" |
| 4 | |
| 5 | DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib" |
| 6 | |
| 7 | SRC_URI = "git://gitlab.freedesktop.org/upower/upower.git;protocol=https;branch=master" |
| 8 | SRCREV = "0f6cc0a10be22d7ddd684e1cd851e4364a440494" |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | UPSTREAM_CHECK_GITTAGREGEX = "UPOWER_(?P<pver>\d+(\_\d+)+)" |
| 12 | |
| 13 | inherit autotools pkgconfig gtk-doc gettext gobject-introspection systemd |
| 14 | |
| 15 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 16 | PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist" |
| 17 | PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \ |
| 18 | --without-systemdutildir --without-systemdsystemunitdir,systemd" |
| 19 | |
| 20 | EXTRA_OECONF = " --with-backend=linux" |
| 21 | |
| 22 | SYSTEMD_SERVICE:${PN} = "upower.service" |
| 23 | # don't start on boot by default - dbus does that on demand |
| 24 | SYSTEMD_AUTO_ENABLE = "disable" |
| 25 | |
| 26 | do_configure:prepend() { |
| 27 | touch ${S}/ABOUT-NLS |
| 28 | mkdir -p ${S}/build-aux |
| 29 | touch ${S}/build-aux/config.rpath |
| 30 | sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am |
| 31 | sed -i -e 's: doc : :g' ${S}/Makefile.am |
| 32 | } |
| 33 | |
| 34 | RDEPENDS:${PN} += "dbus" |
| 35 | RRECOMMENDS:${PN} += "pm-utils" |
| 36 | FILES:${PN} += "${datadir}/dbus-1/ \ |
| 37 | ${base_libdir}/udev/* \ |
| 38 | " |