Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 1 | DESCRIPTION = "Google gRPC" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0 & BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6e4cf218112648d22420a84281b68b88" |
| 6 | |
| 7 | DEPENDS += "${PYTHON_PN}-protobuf" |
| 8 | |
| 9 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| 10 | SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \ |
| 11 | file://boring_ssl.patch \ |
| 12 | file://mips_bigendian.patch \ |
| 13 | file://0001-absl-always-use-asm-sgidefs.h.patch \ |
| 14 | file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "4bae1c99896045d3062ab95478411c8d5a52cb84b91a1517312629fa6cfeb50e" |
| 17 | |
| 18 | RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \ |
| 19 | ${PYTHON_PN}-setuptools \ |
| 20 | ${PYTHON_PN}-six \ |
| 21 | " |
| 22 | |
| 23 | inherit setuptools3 |
| 24 | inherit pypi |
| 25 | |
| 26 | export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" |
| 27 | |
| 28 | BORING_SSL_PLATFORM:arm = "linux-arm" |
| 29 | BORING_SSL_PLATFORM:x86-64 = "linux-x86_64" |
| 30 | BORING_SSL_PLATFORM ?= "unsupported" |
| 31 | export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" |
| 32 | |
| 33 | BORING_SSL:x86-64 = "1" |
| 34 | BORING_SSL:arm = "1" |
| 35 | BORING_SSL ?= "0" |
| 36 | export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" |
| 37 | |
| 38 | GRPC_CFLAGS ?= "" |
| 39 | GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" |
| 40 | export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" |
| 41 | |
| 42 | CLEANBROKEN = "1" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |
| 45 | |
| 46 | CCACHE_DISABLE = "1" |