Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 1 | SUMMARY = "Python project template generator with batteries included" |
| 2 | DESCRIPTION = "PyScaffold package helps to setup a new Python project. \ |
| 3 | After installation, it provides a new command [putup], which could be \ |
| 4 | used to create template Projects." |
| 5 | |
| 6 | HOMEPAGE = "https://github.com/pyscaffold/pyscaffold" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "0BSD & MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91" |
| 10 | DEPENDS += "python3-setuptools-scm-native" |
| 11 | |
| 12 | SRC_URI[sha256sum] = "55f6532fd6d62b3b698d604257f7a7eda6a87557bbec22760f8c0d9549454802" |
| 13 | |
| 14 | inherit pypi python_setuptools_build_meta |
| 15 | PYPI_PACKAGE = "PyScaffold" |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | python3-email \ |
| 19 | python3-compression \ |
| 20 | " |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |