Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Utilities for managing LZMA compressed files" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://tukaani.org/xz/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "XZ Utils is free general-purpose data compression software with a high compression ratio. XZ Utils were written for POSIX-like systems, but also work on some not-so-POSIX systems. XZ Utils are the successor to LZMA Utils." |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | SECTION = "base" |
| 5 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 6 | # The source includes bits of PD, GPL-2.0, GPL-3.0, LGPL-2.1-or-later, but the |
| 7 | # only file which is GPL-3.0 is an m4 macro which isn't shipped in any of our |
| 8 | # packages, and the LGPL bits are under lib/, which appears to be used for |
| 9 | # libgnu, which appears to be used for DOS builds. So we're left with |
| 10 | # GPL-2.0-or-later and PD. |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | LICENSE = "GPL-2.0-or-later & GPL-3.0-with-autoconf-exception & LGPL-2.1-or-later & PD" |
| 12 | LICENSE:${PN} = "GPL-2.0-or-later" |
| 13 | LICENSE:${PN}-dev = "GPL-2.0-or-later" |
| 14 | LICENSE:${PN}-staticdev = "GPL-2.0-or-later" |
| 15 | LICENSE:${PN}-doc = "GPL-2.0-or-later" |
| 16 | LICENSE:${PN}-dbg = "GPL-2.0-or-later" |
| 17 | LICENSE:${PN}-locale = "GPL-2.0-or-later" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | LICENSE:liblzma = "PD" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \ |
| 21 | file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 22 | file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| 23 | file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 24 | file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \ |
| 25 | " |
| 26 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | SRC_URI = "https://tukaani.org/xz/xz-${PV}.tar.gz" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 28 | SRC_URI[md5sum] = "0d270c997aff29708c74d53f599ef717" |
| 29 | SRC_URI[sha256sum] = "f6f4910fd033078738bd82bfba4f49219d03b17eb0794eb91efbae419f4aba10" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar" |
| 31 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh" |
| 33 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | inherit autotools gettext |
| 35 | |
| 36 | PACKAGES =+ "liblzma" |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:liblzma = "${libdir}/liblzma*${SOLIBS}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | |
| 40 | inherit update-alternatives |
| 41 | ALTERNATIVE_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | ALTERNATIVE:${PN} = "xz xzcat unxz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 43 | lzma lzcat unlzma" |
| 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |