Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Simple powerful testing with python" |
| 2 | |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" |
| 5 | |
| 6 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch " |
| 7 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame^] | 8 | SRC_URI[sha256sum] = "9d1edf9e7d0b84d72ea3dbcdfd22b35fb543a5e8f2a60092dd578936bf63d7f9" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 9 | |
| 10 | inherit update-alternatives pypi setuptools3 |
| 11 | |
| 12 | RDEPENDS_${PN}_class-target += " \ |
| 13 | ${PYTHON_PN}-atomicwrites \ |
| 14 | ${PYTHON_PN}-attrs \ |
| 15 | ${PYTHON_PN}-debugger \ |
| 16 | ${PYTHON_PN}-doctest \ |
| 17 | ${PYTHON_PN}-importlib-metadata \ |
| 18 | ${PYTHON_PN}-iniconfig \ |
| 19 | ${PYTHON_PN}-json \ |
| 20 | ${PYTHON_PN}-more-itertools \ |
| 21 | ${PYTHON_PN}-packaging \ |
| 22 | ${PYTHON_PN}-pathlib2 \ |
| 23 | ${PYTHON_PN}-pluggy \ |
| 24 | ${PYTHON_PN}-py \ |
| 25 | ${PYTHON_PN}-setuptools \ |
| 26 | ${PYTHON_PN}-six \ |
| 27 | ${PYTHON_PN}-toml \ |
| 28 | ${PYTHON_PN}-wcwidth \ |
| 29 | " |
| 30 | |
| 31 | ALTERNATIVE_${PN} += "py.test pytest" |
| 32 | |
| 33 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" |
| 34 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" |
| 35 | |
| 36 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" |
| 37 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |