Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | # Recipe for building gutenprint-native |
| 2 | # |
| 3 | # Native part is for generating strings - xmli18n-tmp.h used by target recipe |
| 4 | # We don't depend on cups as this is for generating the string header. |
| 5 | # |
| 6 | # Copyright (c) Ambu A/S - All rights reserved |
| 7 | # SPDX-License-Identifier: MIT |
| 8 | # |
| 9 | # Author(s) |
| 10 | # clst@ambu.com (Claus Stovgaard) |
| 11 | # |
| 12 | |
| 13 | require gutenprint.inc |
| 14 | |
| 15 | # We could consider switching to BBCLASSEXTEND native instead of inherit |
| 16 | # Using devtool with this results in warning, as devtool append externalsrc to |
| 17 | # inheritance, making native not being inherited last. |
| 18 | inherit autotools-brokensep pkgconfig native |
| 19 | |
| 20 | SECTION = "libs" |
| 21 | |
| 22 | # binutils is for xz etc. |
| 23 | # gettext-native for configuration |
| 24 | # flex-native is used for compilation |
| 25 | # byacc-native is for yacc command (compilation) |
| 26 | DEPENDS += "binutils-native gettext-native flex-native byacc-native" |
| 27 | |
| 28 | EXTRA_OECONF = "--without-doc --without-cups" |
| 29 | |
| 30 | # gutenprint does not have a configure file in its root folder. |
| 31 | # Rather it has a autogen.sh in its root folder. We just use it |
| 32 | do_configure() { |
| 33 | ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh" |
| 34 | oe_runconf |
| 35 | } |
| 36 | |
| 37 | # Currently we only uses the string header, even though we compile the complete |
| 38 | # native version of the library. So we limit the install to the needed. |
| 39 | do_install() { |
| 40 | install -d ${D}${datadir}/gutenprint/ |
| 41 | install -m644 ${B}/src/xml/xmli18n-tmp.h ${D}${datadir}/gutenprint/ |
| 42 | } |