Brad Bishop | 3077a7f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC - Applications" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
| 5 | inherit obmc-phosphor-utils |
| 6 | inherit obmc-phosphor-license |
| 7 | |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 8 | PROVIDES = "${PACKAGES}" |
| 9 | PACKAGES = " \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 10 | ${PN}-bmc-state-mgmt \ |
| 11 | ${PN}-chassis-state-mgmt \ |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 12 | ${PN}-extras \ |
| 13 | ${PN}-extrasdev \ |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 14 | ${PN}-fan-control \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 15 | ${PN}-host-state-mgmt \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 16 | ${PN}-inventory \ |
| 17 | ${PN}-leds \ |
| 18 | ${PN}-sensors \ |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 19 | ${PN}-software \ |
Andrew Geissler | b1afecc | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 20 | ${PN}-host-check-mgmt \ |
Jayanth Othayoth | 9be81b1 | 2017-05-08 09:25:05 -0500 | [diff] [blame^] | 21 | ${PN}-debug-collector \ |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 22 | " |
| 23 | |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 24 | SUMMARY_${PN}-bmc-state-mgmt = "BMC state management" |
| 25 | RDEPENDS_${PN}-bmc-state-mgmt = " \ |
| 26 | ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \ |
| 27 | " |
| 28 | |
| 29 | SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management" |
| 30 | RDEPENDS_${PN}-chassis-state-mgmt = " \ |
| 31 | ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \ |
| 32 | " |
| 33 | |
Andrew Geissler | b1afecc | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 34 | SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset" |
| 35 | RDEPENDS_${PN}-host-check-mgmt = " \ |
| 36 | ${VIRTUAL-RUNTIME_obmc-host-check} \ |
| 37 | " |
| 38 | |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 39 | SUMMARY_${PN}-extras = "Extra features" |
| 40 | RDEPENDS_${PN}-extras = " \ |
Brad Bishop | 3077a7f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 41 | phosphor-rest \ |
Brad Bishop | 70436da | 2015-09-16 14:49:27 -0400 | [diff] [blame] | 42 | " |
| 43 | |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 44 | SUMMARY_${PN}-extrasdev = "Development features" |
| 45 | RDEPENDS_${PN}-extrasdev = " \ |
Adriana Kobylak | a3e925f | 2016-06-16 14:46:06 -0500 | [diff] [blame] | 46 | rest-dbus \ |
| 47 | " |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 48 | |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 49 | # Use the fan control package group for applications |
| 50 | # implementing fan control or system fan policy only. |
| 51 | # Applications that create inventory or sensors should |
| 52 | # be added those respective package groups instead. |
| 53 | SUMMARY_${PN}-fan-control = "Fan control" |
| 54 | RDEPENDS_${PN}-fan-control = " \ |
| 55 | " |
| 56 | |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 57 | SUMMARY_${PN}-host-state-mgmt = "Host state management" |
| 58 | RDEPENDS_${PN}-host-state-mgmt = " \ |
| 59 | ${VIRTUAL-RUNTIME_obmc-host-state-manager} \ |
Michael Tritz | b3b5899 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 60 | ${VIRTUAL-RUNTIME_obmc-discover-system-state} \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 61 | " |
| 62 | |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 63 | SUMMARY_${PN}-inventory = "Inventory applications" |
| 64 | RDEPENDS_${PN}-inventory = " \ |
| 65 | ${VIRTUAL-RUNTIME_obmc-inventory-manager} \ |
Matthew Barth | acd9fe4 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 66 | ${VIRTUAL-RUNTIME_obmc-fan-presence} \ |
Brad Bishop | d4c3848 | 2017-04-11 22:12:56 -0400 | [diff] [blame] | 67 | phosphor-chassis-cooling-type \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 68 | " |
| 69 | |
| 70 | SUMMARY_${PN}-leds = "LED applications" |
| 71 | RDEPENDS_${PN}-leds = " \ |
Brad Bishop | af7d060 | 2017-02-27 11:59:49 -0500 | [diff] [blame] | 72 | ${VIRTUAL-RUNTIME_obmc-leds-manager} \ |
| 73 | ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 74 | " |
| 75 | |
| 76 | SUMMARY_${PN}-sensors = "Sensor applications" |
| 77 | RDEPENDS_${PN}-sensors = " \ |
| 78 | ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \ |
| 79 | " |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 80 | |
| 81 | SUMMARY_${PN}-software = "Software applications" |
| 82 | RDEPENDS_${PN}-software = " \ |
| 83 | ${VIRTUAL-RUNTIME_obmc-bmc-code-mgr} \ |
Deepak Kodihalli | b74ceea | 2017-04-13 23:23:42 -0500 | [diff] [blame] | 84 | ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \ |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 85 | " |
Jayanth Othayoth | 9be81b1 | 2017-05-08 09:25:05 -0500 | [diff] [blame^] | 86 | SUMMARY_${PN}-debug-collector = "BMC debug collector" |
| 87 | RDEPENDS_${PN}-debug-collector = " \ |
| 88 | ${VIRTUAL-RUNTIME_obmc-debug-collector} \ |