Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Host side USB console utilities" |
| 2 | DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus." |
| 3 | HOMEPAGE = "http://www.linux-usb.org" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+ & (GPLv2 | GPLv3)" |
| 7 | # License files went missing in 010, when 011 is released add LICENSES/* back |
| 8 | LIC_FILES_CHKSUM = "file://lsusb.c;endline=1;md5=7d4861d978ff5ba7cb2b319ed1d4afe3 \ |
| 9 | file://lsusb.py.in;beginline=2;endline=2;md5=194d6a0226bf90f4f683e8968878b6cd" |
| 10 | |
| 11 | DEPENDS = "libusb1 virtual/libiconv udev" |
| 12 | |
| 13 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \ |
| 14 | file://usb-devices-avoid-dependency-on-bash.patch \ |
| 15 | " |
| 16 | SRC_URI[md5sum] = "5eb2d2d68f9ed6dc3e9659a5988f7ed6" |
| 17 | SRC_URI[sha256sum] = "881ba47fb2df10c3ba54a4cd6755a90377180890788e476f99d480ea9bc8bb58" |
| 18 | |
| 19 | inherit autotools pkgconfig distro_features_check update-alternatives |
| 20 | |
| 21 | ALTERNATIVE_${PN} = "lsusb" |
| 22 | ALTERNATIVE_PRIORITY = "100" |
| 23 | |
| 24 | # The binaries are mostly GPLv2+ apart from lsusb.py which is GPLv2 or v3. |
| 25 | LICENSE_${PN} = "GPLv2+" |
| 26 | LICENSE_${PN}-python = "GPLv2 | GPLv3" |
| 27 | |
| 28 | RRECOMMENDS_${PN} = "udev-hwdb" |
| 29 | |
| 30 | PACKAGE_BEFORE_PN =+ "${PN}-python" |
| 31 | FILES_${PN}-python += "${bindir}/lsusb.py" |
| 32 | RDEPENDS_${PN}-python = "python3-core" |