Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools to Manage Multipathed Devices with the device-mapper" |
| 2 | DESCRIPTION = "This package provides the tools to manage multipathed devices by \ |
| 3 | instructing the device-mapper multipath module what to do" |
| 4 | |
| 5 | HOMEPAGE = "http://christophe.varoqui.free.fr/" |
| 6 | DEPENDS = "readline libaio lvm2 udev" |
| 7 | LICENSE = "GPLv2" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d" |
| 10 | S="${WORKDIR}/git" |
| 11 | |
| 12 | |
| 13 | SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http" |
| 14 | |
| 15 | SRCREV = "d3683ab18b386e9b3b54b59a122c689e9ebdf5cf" |
| 16 | PV = "0.4.9+gitr${SRCPV}" |
| 17 | |
| 18 | inherit autotools-brokensep |
| 19 | |
| 20 | EXTRA_OEMAKE="LIB=${libdir} exec_prefix=${exec_prefix} libdir=${libdir}" |
| 21 | |
| 22 | PACKAGES =+ "libmpathpersist mpathpersist kpartx libmultipath multipath multipathd libmultipath-dev libmpathpersist-dev" |
| 23 | |
| 24 | |
| 25 | RDEPENDS_${PN} += "libmpathpersist mpathpersist kpartx libmultipath multipath multipathd udev" |
| 26 | |
| 27 | do_install_append () { |
| 28 | ln -sf libmpathpersist.so.0 ${D}${libdir}/libmpathpersist.so |
| 29 | ln -sf libmultipath.so.0 ${D}${libdir}/libmultipath.so |
| 30 | } |
| 31 | |
| 32 | ALLOW_EMPTY_${PN} = "1" |
| 33 | FILES_${PN} = "" |
| 34 | |
| 35 | FILES_libmpathpersist = "${libdir}/libmpathpersist*.so.0" |
| 36 | FILES_mpathpersist = "${sbindir}/mpathpersist" |
| 37 | FILES_kpartx = "${sbindir}/kpartx ${base_libdir}/udev/" |
| 38 | FILES_libmultipath = "${libdir}/libcheck*.so ${libdir}/libpri*.so ${libdir}/libmultipath*.so.0" |
| 39 | FILES_multipath = "${sbindir}/multipath ${sysconfdir}" |
| 40 | FILES_multipathd = "${sbindir}/multipathd ${base_libdir}" |
| 41 | |
| 42 | #put the symbol link lib in -dev |
| 43 | FILES_libmultipath-dev = "${libdir}/libmultipath*.so" |
| 44 | FILES_libmpathpersist-dev = "${libdir}/libmpathpersist*.so" |
| 45 | |
| 46 | |