Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python. " |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=795ecad0d261c998cc526c84a822dff6" |
| 6 | |
| 7 | SRC_URI = "git://github.com/h5py/h5py.git \ |
| 8 | file://0001-cross-compiling-support.patch \ |
| 9 | " |
| 10 | SRCREV ?= "8d96a14c3508de1bde77aec5db302e478dc5dbc4" |
| 11 | |
| 12 | inherit setuptools3 |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | DEPENDS = "python3-pkgconfig-native \ |
| 19 | python3-cython-native \ |
| 20 | python3-numpy-native \ |
| 21 | python3-six-native \ |
| 22 | python3 \ |
| 23 | hdf5 \ |
| 24 | " |
| 25 | |
| 26 | RDEPENDS_${PN} = "python3-numpy \ |
| 27 | python3-six \ |
| 28 | " |
| 29 | |
| 30 | export HDF5_VERSION="1.8.19" |