Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Online documentation tools" |
| 2 | DESCRIPTION = "A set of documentation tools: man, apropos and whatis" |
| 3 | SECTION = "console/utils" |
| 4 | HOMEPAGE = "http://primates.ximian.com/~flucifredi/man" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
| 7 | |
| 8 | PR = "r1" |
| 9 | |
| 10 | DEPENDS = "groff less" |
| 11 | |
| 12 | def compress_pkg(d): |
| 13 | if "compress_doc" in (d.getVar("INHERIT", True) or "").split(): |
| 14 | compress = d.getVar("DOC_COMPRESS", True) |
| 15 | if compress == "gz": |
| 16 | return "gzip" |
| 17 | elif compress == "bz2": |
| 18 | return "bzip2" |
| 19 | elif compress == "xz": |
| 20 | return "xz" |
| 21 | return "" |
| 22 | |
| 23 | RDEPENDS_${PN} += "${@compress_pkg(d)}" |
| 24 | |
| 25 | SRC_URI = "http://pkgs.fedoraproject.org/lookaside/pkgs/man2html/${BP}.tar.gz/ba154d5796928b841c9c69f0ae376660/${BP}.tar.gz \ |
| 26 | file://man-1.5k-confpath.patch;striplevel=0 \ |
| 27 | file://man-1.5h1-make.patch \ |
| 28 | file://man-1.5k-nonascii.patch \ |
| 29 | file://man-1.6e-security.patch \ |
| 30 | file://man-1.6e-mandirs.patch \ |
| 31 | file://man-1.5m2-bug11621.patch \ |
| 32 | file://man-1.5k-sofix.patch \ |
| 33 | file://man-1.5m2-buildroot.patch \ |
| 34 | file://man-1.6e-ro_usr.patch \ |
| 35 | file://man-1.5i2-newline.patch;striplevel=0 \ |
| 36 | file://man-1.5j-utf8.patch \ |
| 37 | file://man-1.5i2-overflow.patch \ |
| 38 | file://man-1.5j-nocache.patch \ |
| 39 | file://man-1.5i2-initial.patch \ |
| 40 | file://man-1.5h1-gencat.patch;striplevel=0 \ |
| 41 | file://man-1.5g-nonrootbuild.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 42 | file://man-1.5j-i18n.patch \ |
| 43 | file://man-1.6e-whatis2.patch \ |
| 44 | file://man-1.6e-use_i18n_vars_in_a_std_way.patch \ |
| 45 | file://man-1.5m2-no-color-for-printing.patch \ |
| 46 | file://man-1.5m2-sigpipe.patch \ |
| 47 | file://man-1.6e-i18n_whatis.patch \ |
| 48 | file://man-1.6e-new_sections.patch \ |
| 49 | file://man.1.gz;unpack=false \ |
| 50 | file://man.7.gz;unpack=false \ |
| 51 | file://man.conf \ |
| 52 | file://manpath.5.gz;unpack=false \ |
| 53 | file://man-1.6g-whatis3.patch \ |
| 54 | file://configure_sed.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 55 | file://man-1.6g-parallel.patch \ |
| 56 | file://man-1.6g-compile-warnings.patch \ |
| 57 | file://man-1.6g-configure.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 58 | " |
| 59 | |
| 60 | SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660" |
| 61 | SRC_URI[sha256sum] = "ccdcb8c3f4e0080923d7e818f0e4a202db26c46415eaef361387c20995b8959f" |
| 62 | |
| 63 | CFLAGS += "-DSYSV" |
| 64 | |
| 65 | do_configure () { |
| 66 | ${S}/configure -default -confdir /etc +sgid +fhs +lang all |
| 67 | } |
| 68 | |
| 69 | |
| 70 | do_install() { |
| 71 | oe_runmake install DESTDIR=${D} |
| 72 | } |
| 73 | |
| 74 | do_install_append(){ |
| 75 | mkdir -p ${D}${sysconfdir} |
| 76 | mkdir -p ${D}${datadir}/man/man5 |
| 77 | mkdir -p ${D}${datadir}/man/man7 |
| 78 | cp ${WORKDIR}/man.conf ${D}${sysconfdir}/man.config |
| 79 | cp ${WORKDIR}/man.1.gz ${D}${datadir}/man/man1/ |
| 80 | cp ${WORKDIR}/man.7.gz ${D}${datadir}/man/man7/ |
| 81 | cp ${WORKDIR}/manpath.5.gz ${D}${datadir}/man/man5/ |
| 82 | } |
| 83 | |
| 84 | |
| 85 | RDEPENDS_${PN} = "less groff" |
| 86 | FILES_${PN} += "${datadir}/locale ${sysconfdir}/man.config" |