Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "The shared library for the S-Lang extension language" |
| 2 | |
| 3 | DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \ |
| 4 | S-Lang language was designed so that it can be easily embedded into \ |
| 5 | a program to provide the program with a powerful extension language. \ |
| 6 | The S-Lang library, provided in this package, provides the S-Lang \ |
| 7 | extension language. S-Lang's syntax resembles C, which makes it easy \ |
| 8 | to recode S-Lang procedures in C if you need to." |
| 9 | |
| 10 | HOMEPAGE = "http://www.jedsoft.org/slang/" |
| 11 | SECTION = "libs" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 12 | DEPENDS = "pcre ncurses" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | PR = "r12" |
| 14 | |
| 15 | LICENSE = "GPLv2" |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02" |
| 17 | |
| 18 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 19 | SRC_URI = "http://www.jedsoft.org/releases/slang/old/slang-${PV}.tar.bz2 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | file://rpathfix.patch \ |
| 21 | file://fix-check-pcre.patch \ |
| 22 | file://change-char-type-to-signed-char-in-macros.patch \ |
| 23 | file://sprintf-bug-concerning-8-bit-characters.patch \ |
| 24 | file://slang-fix-the-iconv-existence-checking.patch \ |
| 25 | file://0001-Fix-error-conflicting-types-for-posix_close.patch \ |
| 26 | " |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 27 | UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
| 29 | inherit autotools-brokensep |
| 30 | |
| 31 | CLEANBROKEN = "1" |
| 32 | |
| 33 | SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487" |
| 34 | SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db" |
| 35 | |
| 36 | EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib" |
| 37 | |
| 38 | do_configure_prepend() { |
| 39 | # slang keeps configure.ac and rest of autoconf files in autoconf/ directory |
| 40 | # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac} |
| 41 | # to be present. Resulting files land in autoconf/autoconf/ so we need to move them. |
| 42 | cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* . |
| 43 | cd ${B} |
| 44 | } |
| 45 | |
| 46 | do_install() { |
| 47 | oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib' |
| 48 | } |
| 49 | |
| 50 | FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 51 | |
| 52 | PARALLEL_MAKE = "" |
| 53 | |
| 54 | BBCLASSEXTEND = "native" |