Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 1 | SUMMARY = "C library and tools for interacting with the linux GPIO character device" |
| 2 | AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 4 | LICENSE = "LGPLv2.1+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 7 | SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 8 | SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112" |
| 9 | SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 11 | inherit autotools pkgconfig python3native |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 14 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
| 16 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 17 | # Enable cxx bindings by default. |
| 18 | PACKAGECONFIG ?= "cxx" |
| 19 | |
| 20 | # Always build tools - they don't have any additional |
| 21 | # requirements over the library. |
| 22 | EXTRA_OECONF = "--enable-tools" |
| 23 | |
| 24 | DEPENDS += "autoconf-archive-native" |
| 25 | |
| 26 | PACKAGES =+ "${PN}-tools libgpiodcxx" |
| 27 | FILES_${PN}-tools = "${bindir}/*" |
| 28 | FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
| 30 | PACKAGES =+ "${PN}-python" |
| 31 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 32 | RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}" |
| 33 | RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}" |