Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 1 | SUMMARY = "A client-side C library implementing the SSH2 protocol" |
| 2 | HOMEPAGE = "http://www.libssh2.org/" |
| 3 | SECTION = "libs" |
| 4 | |
| 5 | DEPENDS = "zlib" |
| 6 | |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca" |
| 9 | |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 10 | SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \ |
| 11 | file://CVE-2019-17498.patch \ |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 12 | file://run-ptest \ |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 13 | " |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 14 | SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927" |
| 15 | SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd" |
| 16 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 17 | inherit autotools pkgconfig ptest |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 18 | |
| 19 | EXTRA_OECONF += "\ |
| 20 | --with-libz \ |
| 21 | --with-libz-prefix=${STAGING_LIBDIR} \ |
| 22 | " |
| 23 | |
| 24 | # only one of openssl and gcrypt could be set |
| 25 | PACKAGECONFIG ??= "openssl" |
| 26 | PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl" |
| 27 | PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt" |
| 28 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 29 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame^] | 30 | |
| 31 | RDEPENDS_${PN}-ptest = "bash" |
| 32 | |
| 33 | do_compile_ptest() { |
| 34 | sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile |
| 35 | oe_runmake check |
| 36 | } |
| 37 | |
| 38 | do_install_ptest() { |
| 39 | install -d ${D}${PTEST_PATH}/tests |
| 40 | install -m 0755 ${B}/tests/.libs/simple ${D}${PTEST_PATH}/tests/ |
| 41 | install -m 0755 ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/ |
| 42 | install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/ |
| 43 | } |