Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Software Construction tool (make/autotools replacement)" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=37bb53a08e6beaea0c90e7821d731284" |
| 5 | |
| 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz" |
Brad Bishop | c68388fc | 2019-08-26 01:33:31 -0400 | [diff] [blame] | 7 | SRC_URI[md5sum] = "35b2a3993313bbedd221d4d5758fd2fd" |
| 8 | SRC_URI[sha256sum] = "4cea417fdd7499a36f407923d03b4b7000b0f9e8fd7b31b316b9ce7eba9143a5" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/scons-${PV}" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html" |
| 13 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" |
| 14 | |
| 15 | inherit setuptools3 |
| 16 | |
| 17 | do_install_prepend() { |
| 18 | sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/* |
| 19 | } |
| 20 | |
| 21 | RDEPENDS_${PN} = "\ |
| 22 | python3-core \ |
| 23 | python3-fcntl \ |
| 24 | python3-io \ |
| 25 | python3-json \ |
| 26 | python3-shell \ |
| 27 | python3-pickle \ |
| 28 | python3-pprint \ |
| 29 | " |