Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Enchant Spell checker API Library" |
| 2 | SECTION = "libs" |
| 3 | HOMEPAGE = "http://www.abisource.com/projects/enchant/" |
| 4 | BUGTRACKER = "http://bugzilla.abisource.com/enter_bug.cgi?product=Enchant" |
| 5 | |
| 6 | LICENSE = "LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=dfcbabf9131dc9a95febef6753a2958b \ |
| 8 | file://src/enchant.h;beginline=1;endline=29;md5=8d881caa1d37523567e1d8f726675a18" |
| 9 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 10 | DEPENDS = "glib-2.0" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | inherit autotools pkgconfig |
| 13 | |
| 14 | PR = "r3" |
| 15 | |
| 16 | SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz" |
| 17 | |
| 18 | SRC_URI[md5sum] = "de11011aff801dc61042828041fb59c7" |
| 19 | SRC_URI[sha256sum] = "2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03f7097f" |
| 20 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 21 | PACKAGECONFIG ??= "aspell" |
| 22 | PACKAGECONFIG[aspell] = " --with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell, --disable-aspell, aspell, aspell" |
| 23 | PACKAGECONFIG[ispell] = " --with-ispell-prefix=${STAGING_DIR_HOST}${prefix} --enable-ispell, --disable-ispell, ispell, ispell" |
| 24 | PACKAGECONFIG[uspell] = " --with-uspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-uspell, --disable-uspell, uspell, uspell" |
| 25 | PACKAGECONFIG[hspell] = " --with-hspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-hspell, --disable-hspell, hspell, hspell" |
| 26 | PACKAGECONFIG[myspell] = "--with-myspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-myspell, --disable-myspell, myspell, myspell" |
| 27 | |
| 28 | EXTRA_OECONF = "br_cv_binreloc=no" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | |
| 30 | export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ " |
| 31 | |
| 32 | FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${BPN} ${libdir}/${BPN}/*.so" |
| 33 | FILES_${PN}-dev += "${libdir}/${BPN}/*{SOLIBSDEV} ${libdir}/${BPN}/*.la" |
| 34 | FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a" |