Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "ZeroMQ looks like an embeddable networking library but acts like a concurrency framework" |
| 2 | HOMEPAGE = "http://www.zeromq.org" |
| 3 | LICENSE = "LGPLv3+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=d5311495d952062e0e4fbba39cbf3de1" |
| 5 | |
| 6 | PACKAGECONFIG ??= "libsodium" |
| 7 | PACKAGECONFIG[libsodium] = "--with-libsodium, --without-libsodium, libsodium" |
| 8 | |
| 9 | SRC_URI = "http://github.com/zeromq/libzmq/releases/download/v${PV}/zeromq-${PV}.tar.gz \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "a1c95b34384257e986842f4d006957b8" |
| 13 | SRC_URI[sha256sum] = "cc9090ba35713d59bb2f7d7965f877036c49c5558ea0c290b0dcc6f2a17e489f" |
| 14 | |
| 15 | S = "${WORKDIR}/zeromq-${PV}" |
| 16 | |
| 17 | #Uncomment to choose polling system manually. valid values are kqueue, epoll, devpoll, poll or select |
| 18 | #EXTRA_OECONF += "--with-poller=kqueue" |
| 19 | #CFLAGS_append = " -O0" |
| 20 | #CXXFLAGS_append = " -O0" |
| 21 | |
| 22 | inherit autotools ptest pkgconfig |
| 23 | |
| 24 | do_compile_ptest () { |
| 25 | echo 'buildtest-TESTS: $(check_PROGRAMS)' >> ${B}/Makefile |
| 26 | oe_runmake buildtest-TESTS |
| 27 | } |
| 28 | |
| 29 | do_install_ptest () { |
| 30 | install -d ${D}${PTEST_PATH}/tests |
| 31 | install -m 0755 ${B}/tests/.libs/test_* ${D}${PTEST_PATH}/tests |
| 32 | } |