Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A graphical front-end for gcov" |
| 2 | HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php" |
| 3 | DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \ |
| 4 | tool gcov. It collects gcov data for multiple source files and creates \ |
| 5 | HTML pages containing the source code annotated with coverage information. \ |
| 6 | It also adds overview pages for easy navigation within the file structure. \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 7 | LCOV supports statement, function and branch coverage measurement." |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | LICENSE = "GPL-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 10 | |
| 11 | RDEPENDS_${PN} += " \ |
| 12 | gcov \ |
| 13 | perl \ |
| 14 | perl-module-filehandle \ |
| 15 | perl-module-getopt-std \ |
| 16 | perl-module-digest-sha \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI = "http://downloads.sourceforge.net/ltp/${BP}.tar.gz" |
| 20 | |
| 21 | SRC_URI[md5sum] = "e79b799ae3ce149aa924c7520e993024" |
| 22 | SRC_URI[sha256sum] = "c282de8d678ecbfda32ce4b5c85fc02f77c2a39a062f068bd8e774d29ddc9bf8" |
| 23 | |
| 24 | do_install() { |
| 25 | oe_runmake install PREFIX=${D} |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | } |
| 27 | |