Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \ |
| 2 | package" |
| 3 | LICENSE = "PD" |
| 4 | LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;endline=21;md5=8fbd0497a7d0b01e99820bffcb58e9ad" |
| 5 | # start-stop-daemon is usually shipped by dpkg |
| 6 | DEPENDS = "ncurses" |
| 7 | RCONFLICTS_${PN} = "dpkg" |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | ${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.xz \ |
| 11 | file://0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "e48fcfdb2162e77d72c2a83432d537ca" |
| 15 | SRC_URI[sha256sum] = "07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa" |
| 16 | |
| 17 | inherit autotools gettext pkgconfig |
| 18 | |
| 19 | S = "${WORKDIR}/dpkg-${PV}" |
| 20 | |
| 21 | EXTRA_OECONF = " \ |
| 22 | --without-bz2 \ |
| 23 | --without-selinux \ |
| 24 | " |
| 25 | |
| 26 | do_install_append () { |
| 27 | # remove everything that is not related to start-stop-daemon, since there |
| 28 | # is no explicit rule for only installing ssd |
| 29 | find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \; |
| 30 | find ${D} -depth -type d -empty -exec rmdir {} \; |
| 31 | |
| 32 | # support for buggy init.d scripts that refer to an alternative |
| 33 | # explicit path to start-stop-daemon |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 34 | if [ "${base_sbindir}" != "${sbindir}" ]; then |
| 35 | mkdir -p ${D}${base_sbindir} |
| 36 | ln -sf ${sbindir}/start-stop-daemon ${D}${base_sbindir}/start-stop-daemon |
| 37 | fi |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 38 | } |