Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 1 | SUMMARY = "GNU cpio is a program to manage archives of files" |
| 2 | DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \ |
| 3 | another. It handles a number of cpio formats as well as reading and writing tar files." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/cpio/" |
| 5 | SECTION = "base" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \ |
| 10 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
| 11 | file://0001-Fix-CVE-2015-1197.patch \ |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 12 | file://0001-CVE-2016-2037-1-byte-out-of-bounds-write.patch \ |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame^] | 13 | file://0001-Fix-segfault-with-append.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "fc207561a86b63862eea4b8300313e86" |
| 17 | SRC_URI[sha256sum] = "08a35e92deb3c85d269a0059a27d4140a9667a6369459299d08c17f713a92e73" |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 18 | |
| 19 | inherit autotools gettext texinfo |
| 20 | |
| 21 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${base_sbindir}" |
| 22 | |
| 23 | do_install () { |
| 24 | autotools_do_install |
| 25 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 26 | install -d ${D}${base_bindir}/ |
| 27 | mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio" |
| 28 | rmdir ${D}${bindir}/ |
| 29 | fi |
| 30 | } |
| 31 | |
| 32 | PACKAGES =+ "${PN}-rmt" |
| 33 | |
| 34 | FILES_${PN}-rmt = "${base_sbindir}/rmt*" |
| 35 | |
| 36 | inherit update-alternatives |
| 37 | |
| 38 | ALTERNATIVE_PRIORITY = "100" |
| 39 | |
| 40 | ALTERNATIVE_${PN} = "cpio" |
| 41 | ALTERNATIVE_${PN}-rmt = "rmt" |
| 42 | |
| 43 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 44 | |
| 45 | ALTERNATIVE_PRIORITY[rmt] = "50" |
| 46 | ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt" |
| 47 | |
| 48 | BBCLASSEXTEND = "native" |