blob: ff781f6942ce7302be77cdbf2a7885ecf59b914a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
10 "
Andrew Geisslereafcbb82020-06-05 17:59:17 -050011SRC_URI[md5sum] = "daa93ee2fdaf461e515b4713e7337076"
12SRC_URI[sha256sum] = "c1a9463f1f2175086120e9079e318bbd383dc1e574fafb2f724879f1d11061d4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
15
16inherit perlnative
17
18# The install rule from the Makefile has hardcoded paths, so we duplicate
19# the actions to accommodate different paths.
20do_install () {
21 install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
22 install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
23}