Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Control process attributes through prctl" |
| 2 | DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \ |
| 3 | process' behaviour. Usage of the function is fairly messy though, due to \ |
| 4 | limitations in C and linux. This module provides a nice non-messy python(ic) \ |
| 5 | interface." |
| 6 | SECTION = "devel/python" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5eb2f4bcd60326f83e5deb542372d52f" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | B = "${S}" |
| 12 | |
| 13 | SRCREV = "1107d0be7bec4b28c85c62c454882d16844c930a" |
| 14 | PV = "1.6.1+git${SRCPV}" |
| 15 | |
| 16 | SRC_URI = "git://github.com/seveas/python-prctl;branch=master \ |
| 17 | file://0001-support-cross-complication.patch \ |
| 18 | " |
| 19 | inherit setuptools3 python3native |
| 20 | |
| 21 | DEPENDS += "libcap" |
| 22 | |