Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Build Result Compare Script" |
| 2 | DESCRIPTION = "This package contains scripts to find out if the build result\ |
| 3 | differs to a former build." |
| 4 | HOMEPAGE = "https://github.com/openSUSE/build-compare" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openSUSE/build-compare.git \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | file://Ignore-DWARF-sections.patch;striplevel=1 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | # Date matches entry in build-compare.changes and date of SRCREV. |
| 13 | # |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 14 | SRCREV = "4dfa207660776cae120afa4353aec7f1f2a998d2" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | PE = "1" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 16 | PV = "2019.08.14+git${SRCPV}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}/${bindir} |
| 25 | install -m 755 functions.sh ${D}/${bindir} |
| 26 | install -m 755 pkg-diff.sh ${D}/${bindir} |
| 27 | install -m 755 same-build-result.sh ${D}/${bindir} |
| 28 | install -m 755 srpm-check.sh ${D}/${bindir} |
| 29 | } |
| 30 | |
| 31 | RDEPENDS_${PN} += "bash" |