Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Lossless data compression library" |
| 2 | HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://src/lzo_init.c;beginline=5;endline=25;md5=355023835a9b9eeb70ab895395e951ff" |
| 7 | |
| 8 | SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz \ |
| 9 | file://0001-Use-memcpy-instead-of-reinventing-it.patch \ |
| 10 | file://acinclude.m4 \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "c7ffc9a103afe2d1bba0b015e7aa887f" |
| 15 | SRC_URI[sha256sum] = "f294a7ced313063c057c504257f437c8335c41bfeed23531ee4e6a2b87bcb34c" |
| 16 | |
| 17 | inherit autotools ptest |
| 18 | |
| 19 | EXTRA_OECONF = "--enable-shared" |
| 20 | |
| 21 | do_configure_prepend () { |
| 22 | cp ${WORKDIR}/acinclude.m4 ${S}/ |
| 23 | } |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | t=${D}${PTEST_PATH} |
| 27 | cp ${S}/util/check.sh $t |
| 28 | cp ${B}/minilzo/testmini $t |
| 29 | for i in tests/align tests/chksum lzotest/lzotest examples/simple |
| 30 | do cp ${B}/`dirname $i`/.libs/`basename $i` $t; \ |
| 31 | done |
| 32 | } |
| 33 | |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |