Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | SUMMARY = "File system QA test suite" |
| 2 | LICENSE = "GPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038" |
| 4 | |
| 5 | SRCREV_FORMAT = "xfstests_unionmount" |
| 6 | |
| 7 | SRC_URI = "\ |
| 8 | git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \ |
| 9 | git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ |
| 10 | " |
| 11 | |
| 12 | SRCREV_xfstests = "37881397f1aa62df3c63468049c80b301b0e89eb" |
| 13 | SRCREV_unionmount = "cec4c51a3bf8ba80bb99fc74b302749d4e3d2f1d" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit autotools-brokensep useradd |
| 18 | |
| 19 | DEPENDS += "xfsprogs acl" |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | bash \ |
| 22 | bc \ |
| 23 | coreutils \ |
| 24 | e2fsprogs \ |
| 25 | e2fsprogs-tune2fs \ |
| 26 | e2fsprogs-resize2fs \ |
| 27 | libcap-bin \ |
| 28 | overlayfs-progs \ |
| 29 | perl \ |
| 30 | python3 \ |
| 31 | python3-core \ |
| 32 | xfsprogs \ |
| 33 | acl \ |
| 34 | " |
| 35 | |
| 36 | USERADD_PACKAGES = "${PN}" |
| 37 | # these users are necessary to run the tests |
| 38 | USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2" |
| 39 | |
| 40 | EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root" |
| 41 | |
| 42 | # install-sh script in the project is outdated |
| 43 | # we use the one from the latest libtool to solve installation issues |
| 44 | # It looks like the upstream is not interested in having it fixed :( |
| 45 | # https://www.spinics.net/lists/fstests/msg16981.html |
| 46 | do_configure:prepend() { |
| 47 | cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B} |
| 48 | } |
| 49 | |
| 50 | do_install:append() { |
| 51 | unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite |
| 52 | install -d ${D}/usr/xfstests/unionmount-testsuite/tests |
| 53 | install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests |
| 54 | install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir |
| 55 | install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir |
| 56 | install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir |
| 57 | } |
| 58 | |
| 59 | FILES:${PN} += "\ |
| 60 | /usr/xfstests \ |
| 61 | " |