Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Xilinx Runtime(XRT) libraries" |
| 2 | DESCRIPTION = "Xilinx Runtime User Space Libraries and headers" |
| 3 | |
| 4 | LICENSE = "GPLv2 & Apache-2.0" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \ |
| 6 | file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \ |
| 7 | file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \ |
| 9 | file://runtime_src/core/pcie/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \ |
| 10 | file://runtime_src/core/edge/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame^] | 12 | BRANCH ?= "2020.1_PU1" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 13 | REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https" |
| 14 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 15 | SRC_URI = "${REPO};${BRANCHARG}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame^] | 17 | PV = "202010.2.7.0" |
| 18 | SRCREV ?= "8a4c6eb5012c57423fba468e1af8df53a293dcd5" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git/src" |
| 21 | |
| 22 | inherit cmake |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |
| 25 | |
| 26 | # util-linux is for libuuid-dev. |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 27 | DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 28 | RDEPENDS_${PN} = "bash ocl-icd boost-system boost-filesystem" |
| 29 | |
| 30 | EXTRA_OECMAKE += " \ |
| 31 | -DCMAKE_BUILD_TYPE=Release \ |
| 32 | -DCMAKE_EXPORT_COMPILE_COMANDS=ON \ |
| 33 | " |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 34 | |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame^] | 35 | PACKAGE_ARCH_versal-ai-core = "${SOC_VARIANT_ARCH}" |
| 36 | EXTRA_OECMAKE_append_versal-ai-core += "-DXRT_AIE_BUILD=true" |
| 37 | TARGET_CXXFLAGS_append_versal-ai-core += "-DXRT_ENABLE_AIE" |
| 38 | DEPENDS_append_versal-ai-core += " libmetal libxaiengine" |
| 39 | RDEPENDS_${PN}_append_versal-ai-core += " libxaiengine" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 40 | |
| 41 | pkg_postinst_ontarget_${PN}() { |
| 42 | #!/bin/sh |
| 43 | if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then |
| 44 | echo "INFO: Creating ICD entry for Xilinx Platform" |
| 45 | mkdir -p /etc/OpenCL/vendors |
| 46 | echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd |
| 47 | chmod -R 755 /etc/OpenCL |
| 48 | fi |
| 49 | } |