Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | require gcc-configure-xilinx-standalone.inc |
| 2 | require gcc-xilinx-standalone.inc |
| 3 | |
| 4 | # We want to use the stock multilib configs, when available |
| 5 | EXTRACONFFUNCS_xilinx-standalone = "" |
| 6 | |
| 7 | EXTRA_OECONF_append_xilinx-standalone = " \ |
| 8 | --enable-multilib \ |
| 9 | " |
| 10 | |
| 11 | # Temporary hack to build gcc cross canadian for tclibc-newlib as --with-sysroot=/not/exist |
| 12 | # has been removed from TARGET_OS for elf and eabi in gcc-cross-canadian.inc |
| 13 | |
| 14 | python() { |
| 15 | if 'xilinx-standalone' in d.getVar("DISTROOVERRIDES").split(':'): |
| 16 | extraoeconfgcc = d.getVar('EXTRA_OECONF') |
| 17 | extraoeconfgcc += " --with-sysroot=/not/exist" |
| 18 | d.delVar('EXTRA_OECONF') |
| 19 | d.setVar('EXTRA_OECONF', extraoeconfgcc) |
| 20 | } |