Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Build Result Compare Script" |
| 2 | DESCRIPTION = "This package contains scripts to find out if the build result\ |
| 3 | differs to a former build." |
| 4 | HOMEPAGE = "https://github.com/openSUSE/build-compare" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openSUSE/build-compare.git \ |
| 9 | file://Rename-rpm-check.sh-to-pkg-diff.sh.patch;striplevel=1 \ |
| 10 | file://Ignore-DWARF-sections.patch;striplevel=1 \ |
| 11 | file://0001-Add-support-for-deb-and-ipk-packaging.patch \ |
| 12 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | |
| 14 | SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | BBCLASSEXTEND += "native nativesdk" |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}/${bindir} |
| 22 | install -m 755 functions.sh ${D}/${bindir} |
| 23 | install -m 755 pkg-diff.sh ${D}/${bindir} |
| 24 | install -m 755 same-build-result.sh ${D}/${bindir} |
| 25 | install -m 755 srpm-check.sh ${D}/${bindir} |
| 26 | } |
| 27 | |
| 28 | RDEPENDS_${PN} += "bash" |